hibernate validator jar包是一款常用的hibernate框架工具包,马上下载安装此框架吧,如果您正需要这款hibernate-validator.jar,马上进行hibernate validator下载吧。
 

hibernate validator jar包基本简介

Hibernate是一个开放源代码的对象关系映射框架,它对JDBC进行了非常轻量级的对象封装,它将POJO与数据库表建立映射关系,是一个全自动的orm框架,hibernate可以自动生成SQL语句,自动执行,使得Java程序员可以随心所欲的使用对象编程思维来操纵数据库。 Hibernate可以应用在任何使用JDBC的场合,既可以在Java的客户端程序使用,也可以在Servlet/JSP的Web应用中使用,最具革命意义的是,Hibernate可以在应用EJB的J2EE架构中取代CMP,完成数据持久化的重任。
编程环境

Hibernate是一个以LGPL(Lesser GNU Public License)许可证形式发布的开源项目。在Hibernate官网上有下载Hibernate包的说明。Hibernate包以源代码或者二进制的形式提供。
编程工具

Eclipse:一个开放源代码的、基于Java的可扩展开发平台。
NetBeans:开放源码的Java集成开发环境,适用于各种客户机和Web应用。
IntelliJ IDEA:在代码自动提示、代码分析等方面的具有很好的功能。
MyEclipse:由Genuitec公司开发的一款商业化软件,是应用比较广泛的Java应用程序集成开发环境。
EditPlus:如果正确配置Java的编译器“Javac”以及解释器“Java”后,可直接使用EditPlus编译执行Java程序。
框架解释

1. Bean Validation 中内置的 constraint
注解 - 作用
@Valid - - 被注释的元素是一个对象,需要检查此对象的所有字段值
@Null - - 被注释的元素必须为 null
@NotNull - - 被注释的元素必须不为 null
@AssertTrue - - 被注释的元素必须为 true
@AssertFalse - - 被注释的元素必须为 false
@Min(value) - 被注释的元素必须是一个数字,其值必须大于等于指定的最小值
@Max(value) - 被注释的元素必须是一个数字,其值必须小于等于指定的最大值
@DecimalMin(value) - 被注释的元素必须是一个数字,其值必须大于等于指定的最小值
@DecimalMax(value) - 被注释的元素必须是一个数字,其值必须小于等于指定的最大值
@Size(max, min) - 被注释的元素的大小必须在指定的范围内
@Digits (integer, fraction) - 被注释的元素必须是一个数字,其值必须在可接受的范围内
@Past - 被注释的元素必须是一个过去的日期
@Future - 被注释的元素必须是一个将来的日期
@Pattern(value) - 被注释的元素必须符合指定的正则表达式
2. Hibernate Validator 附加的 constraint
注解 - 作用
@Email - 被注释的元素必须是电子邮箱地址
@Length(min=, max=) - 被注释的字符串的大小必须在指定的范围内
@NotEmpty - 被注释的字符串的必须非空
@Range(min=, max=) - 被注释的元素必须在合适的范围内
@NotBlank - 被注释的字符串的必须非空
@URL(protocol=,host=,port=,regexp=,flags=) - 被注释的字符串必须是一个有效的url
@CreditCardNumber - 银行卡,信用卡等号码一般都用Luhn计算合法性
@ScriptAssert - 要有Java Scripting API 即JSR 223
(lang=, script=, alias=) - ("Scripting for the JavaTM Platform")的实现
@SafeHtml(whitelistType=,additionalTags=) - classpath中要有jsoup包

1. 本站所有文章及资源来源于用户上传和网络,如有侵权请联系站长处理!
2. 分享目的仅供大家学习和交流,您必须在下载后24小时内删除!
3. 不得使用于非法商业用途,不得违反国家法律,否则后果自负!
4. 如有链接无法下载、失效或广告,请联系管理员处理!
5. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!

中国站长社区 » hibernate validator jar包

发表评论