Require.JS (前身是 RunJS) 是一个根据需要来加载 js 文件的 JavaScript 框架,可避免不必要的js文件加载,提升网页浏览速度.

2.1.11
一些bug修复,其中最引人注目的除了是一种优化选择,wrapShim。这将包装在一个定义()调用匀依赖关系,因此,他们在创建后更好地工作时,他们的上游依赖性也AMD的模块依赖关系。
最显着的情况下,很可能是使用主干的AMD感知版本时,但使用垫片配置为依赖于骨干脚本。如果这是你的使用情况,然后设置wrapShim: true:真正的优化配置可能会修复任何后期生成问题,您可能会看到。更多详细信息.
更新列表:
修正 require.js 问题
修正 r.js optimizer 问题

1. 本站所有文章及资源来源于用户上传和网络,如有侵权请联系站长处理!
2. 分享目的仅供大家学习和交流,您必须在下载后24小时内删除!
3. 不得使用于非法商业用途,不得违反国家法律,否则后果自负!
4. 如有链接无法下载、失效或广告,请联系管理员处理!
5. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!

中国站长社区 » require.js 2.1.11

发表评论